2015/03/24

CentOS 6.5 に atomic リポジトリが入っていたのでアンインストールした


CentOS 6.5 にいつの間にか、atomic リポジトリが追加になっていて、yum update をかけると PHP 5.3 が PHP 5.4 になるようになってしまいました。

CentOS 6.5 でサポートされる PHP のバージョンは 5.3.3 なので、atomic リポジトリを削除して、PHP 5.4 をアンインストール後、PHP 5.3.3 を再インストールします。

まずは、下記コマンドを実行し、インストールされているリポジトリを確認します。

# yum repolist

Loaded plugins: fastestmirror, refresh-packagekit

Loading mirror speeds from cached hostfile

 * atomic: www5.atomicorp.com

 * base: www.ftp.ne.jp

 * extras: www.ftp.ne.jp

 * updates: www.ftp.ne.jp

repo id   repo name                                                       status

atomic    CentOS / Red Hat Enterprise Linux 6 - atomicrocketturtle.com    1,686

base      CentOS-6 - Base                                                 6,518

extras    CentOS-6 - Extras                                                  37

updates   CentOS-6 - Updates                                                874

repolist: 9,115

atomic リポジトリがインストールされていますね。一体、いつインストールされたのか。。。

次に、以下のコマンドでインストールされている atomic リポジトリを確認します。

# rpm -qa|grep atomic

atomic-release-1.0-17.el6.art.noarch

バージョンが確認できたので、atomic リポジトリを削除します。

# rpm -e atomic-release-1.0-17.el6.art

再度、下記コマンドでインストールされているリポジトリを確認します。

# yum repolist

Loaded plugins: fastestmirror, refresh-packagekit

Loading mirror speeds from cached hostfile

 * base: www.ftp.ne.jp

 * extras: www.ftp.ne.jp

 * updates: www.ftp.ne.jp

repo id                        repo name                                  status

base                           CentOS-6 - Base                            6,518

extras                         CentOS-6 - Extras                             37

updates                        CentOS-6 - Updates                           874

repolist: 7,429

atomic リポジトリは無事に削除できたようです。

では、PHP 5.4 をアンインストールします。

# yum -y remove php*

そして、PHP 5.3.3 をインストールします。

# yum -y install php*

PHP のバージョンを確認します。

# php -v

No log handling enabled - turning on stderr logging

Created directory: /var/lib/net-snmp/mib_indexes

PHP 5.3.3 (cli) (built: Oct 30 2014 20:12:53) 

Copyright (c) 1997-2010 The PHP Group

Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies

無事に、PHP 5.3.3 をインストールできたようです。

最後に、Apache を再起動しておきます。

# service httpd restart

 

■参考サイト

 


スポンサーリンク


このエントリーをはてなブックマークに追加




Twitter ではブログにはない、いろんな情報を発信しています。


コメント

コメントを書く



プロフィール

  • 名前:fnya
    経歴:
    SE としての経験は15年以上。様々な言語と環境で業務系システム開発を行い、セキュリティ対策などもしていました。現在は趣味SE。

    Twitter では、ブログでは取り上げない情報も公開しています。


    ブログについて

    このブログは、IT、スマートフォン、タブレット、システム開発などに関するさまざまな話題を取り上げたり、雑感などをつづっています。

    現在、Enty で支援を受け付けています。もしよければご支援ください。



    >>ブログ詳細
    >>自作ツール
    >>運営サイト
    >>Windows 10 まとめ

    Twitter のフォローはこちらから Facebook ページはこちら Google+ページはこちら RSSフィードのご登録はこちらから