2009/07/28

Microsoft Anti-Cross Site Scripting Library というものがあるらしい


Download details: Anti-XSS Library V3.0 via もり ひろゆきの日々是勉強さん

ASP.NET のサイトでクロスサイトスクリプティングを防ぐためのライブラリである、Microsoft Anti-Cross Site Scripting Library V3.0 というものが公開されています。

サンプルアプリケーションを見る限りだと、ライブラリをモジュールとして組み込んだ後でコーディングでの対応も必要なようです。もしかしたら違う使い方もあるかもしれませんが。

クロスサイトスクリプティングは SQL インジェクションと並んで非常にセキュリティ上問題になっているので、こういうライブラリを活用するのもよいのではないでしょうか。

なお、システム要件は以下のようになっています。

System Requirements

* Supported Operating Systems: Windows 2000; Windows Server 2003; Windows Server 2008; Windows Vista; Windows XP; Windows XP 64-bit

OS: Microsoft Windows Software: .NET Framework 2.0


スポンサーリンク


このエントリーをはてなブックマークに追加




Twitter ではブログにはない、いろんな情報を発信しています。


コメント

コメントを書く



プロフィール